Введите размер массива n и заполните массив из n элементов числа фибоначчи равны 1, а каждое следующее число равно сумме двух предыдущих. составить программу..
Var n:integer; a:array of integer; begin write('n = '); readln(n); SetLength(a,n); a[0]:=1; a[1]:=1; for var i:=2 to n-1 do a[i]:=a[i-2]+a[i-1]; for var i:=0 to n-1 do write(a[i],' '); writeln; end.
Пример: n = 10 1 1 2 3 5 8 13 21 34 55
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку