nvgaponuk
04.08.2022 19:14

Напишите программу на с++, которая вводит натуральное число n и выводит на экран все натуральные числы, не превосходящие n и делящуеся на каждую из своих цифр

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lenusj1975197514
08.10.2020 00:50
#include <bits/stdc++.h>

using namespace std;

int main()
{
   int n; cin >> n;
   for (int i = 1; i <= n; ++i)
   {
       int tmp = i;
       bool fl = true;
       while (tmp) {
            int x = tmp % 10;
             if (x != 0)
                if (i % x != 0)
                  fl = false;
              if (!x) fl = false;
            tmp /= 10;
       }
       if (fl) cout << i << ' ';
   }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота