Csgopro1
25.09.2020 12:05

1. написать программу, которая подсчитывает количество элементов, четных и оканчивающихся на 6, в массиве целых чисел. количество элементов массива равно n. массив заполнить случайными числами в интервале [20,80). если таких чисел нет, напечатать «нет». 2. написать программу, которая подсчитывает количество пар элементов в массиве, в которых каждый элемент равен второму в паре. в массиве 10 элементов, массив заполняется с случайных чисел из интервала (0, 100).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Алёнушка290
08.10.2020 00:40
1. Если число оканчивается на 6, то оно четное согласно признаку делимости на 2, поэтому проверка на четность не нужна.

// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),20,80); a.Println;
  var k:=a.Where(t->t mod 10=6).Count;
  if k>0 then Writeln(k)
  else Writeln('Нет')
end.

Пример
n= 15
47 53 73 26 75 64 70 32 27 80 29 53 20 62 66
2

2. Достаточно много раз нужно запускать задачу, чтобы суметь получить случайную последовательность с парой одинаковых соседних элементов...

// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,0,100); a.Println;
  var k:=a.Pairwise.Where(t->t[0]=t[1]).Count;
  if k>0 then Writeln(k)
  else Writeln('Нет')
end.

Пример
60 41 87 87 95 75 72 32 8 52
1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота