baxrom2
08.11.2021 19:44

Создать программу python напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. пример: введите два числа: 10 -15 10*(-15)=-150

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
geralump
08.10.2020 00:30
A=int(input('a = '));
b=int(input('b = '));
if (((a<0) & (b>0)) | ((a>0) & (b<0))): sgn=1;
else: sgn=0;
if (a<0): a=-a;
if (b<0): b=-b;
c=0;
while (a>0):
    if ((a & 1)==1): c+=b;
    a>>=1;
    b<<=1;
if (sgn==1): print('результат: ',-c);
else: print('результат: ',c);

a = - 42153689754
b = 7892456310201
результат:  - 332696154697212539380554
    
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота