marisha0606
06.07.2021 20:20

Составить программу в паскале, которая сформирует целочисленный массив из n элементов и увеличит все элементы массива на значение максимального элемента. требования : n - не более заполнения массива - ввод значений с клавиатуры; наличие в массиве положительных и отрицательных элементов; вывод сопровождается: исходный массив, значение максимального элемента, печать массива после внесенных в него изменений, дружественный интерфейс

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
нина503
21.08.2020 11:09
Uses  math;
var  a         : array of longInt;  i, n, max : integer;
begin  write('Введите размер массива');  read(n);  writeln;    setLength(A,n);    writeln('Введите элементы массива');  for i := 0 to n - 1 do read(a[i]);    writeln('Исходный массив:');  for i := 0 to n - 1 do write(a[i], ' ');  writeln;    write('Максимальный элемент: ');  max := MaxIntValue(a);  writeln(max);    writeln('Изменённый массив:');  for i := 0 to n - 1 do  begin      a[i] += max;      write(a[i], ' ');  end;  writeln;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота