coopersmith
14.01.2020 00:35

Решить эти языком паскаля: 1. составить программу для вычисления длины окружности, если радиус r = 5,7,9, 21 см 2. с клавиатуры вводится n действительных чисел. найти количество положительных и количество отрицательных чисел

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Tyxco
07.10.2020 23:52
Program ez_1;

var  s: integer;
a: array [1..9] of integer;\
i: byte;
begin
  a[1] := 5;
  for i := 1 to 9 do
a[i] := a[1] + 2 * i;
 for i := 1 to 9 do
begin
    s := 3 * (a[i] * a[i]);
    writeln(s);
  end;
end.

2)
program ez_2;var
  s, m, b: integer;
  a: array [1..9] of integer;
  i: byte;
begin
  readln(s);
  for i := 1 to s do
  begin
    read(a[i]);
 if a[i] < 0 then m := m + 1
else b := b + 1;
 end;
 writeln(b, ' Положительных чисел');
 writeln(m, ' Отрицательных чисел');
end.

Вроде так. Если что-то не так. Пиши.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота