Нужно на паскаль написать программу, которая будет из данного ряда чисел (5,4,3,5,5,5,4) вычислять в столбец: 1) сколько 5 в данном ряду. 2) сколько 4 в данном ряду. 3) сколько 3 в данном ряду.
Если нужно только эти числа(5,4,3,5,5,5,4), то вот программа. var b,c1,c2,c3:integer; a: array [1..7] of integer; i: byte; begina[1]:=5; a[2]:=4; a[3]:=3; a[4]:=5; a[5]:=5; a[6]:=5; a[7]:=4; for i:= 1 to 7 do
begin case a[i] of 3: c1:=c1+1; 4: c2:=c2+1; 5: c3:=c3+1; end; end; writeln('Количество чисел 5 в данном ряду=',c3); writeln('Количество чисел 4 в данном ряду=',c2); writeln('Количество чисел 3 в данном ряду=',c1); end.
Если нужно только эти числа(5,4,3,5,5,5,4), то вот программа.var b,c1,c2,c3:integer;a: array [1..7] of integer;i: byte;begina[1]:=5;a[2]:=4;a[3]:=3;a[4]:=5;a[5]:=5;a[6]:=5;a[7]:=4;for i:= 1 to 7 do begincase a[i] of3: c1:=c1+1;4: c2:=c2+1;5: c3:=c3+1;end;end;writeln('Количество чисел 5 в данном ряду=',c3);writeln('Количество чисел 4 в данном ряду=',c2);writeln('Количество чисел 3 в данном ряду=',c1);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку