Girl1209
18.05.2023 11:01

Напишите программу треугольник со сторонами, надо. даны длины 3-х отрезков. нужно сказать, можно ли, соединяя отрезки концами, получить равносторонний, равнобедренный или разносторонний треугольники. или неравенство треугольника нарушено и его составить нельзя? input со стандартного устройства ввода вводятся через пробел 3 целых положительных числа, не превосходящих 10000 – длины отрезков. output нужно выдать на стандартное устройство вывода одно из следующих сообщений: “triangle is equilateral” – если треугольник равносторонний, “triangle is isosceles” – если треугольник равнобедренный, “triangle is scalene” – если треугольник разносторонний, “triangle is invalid” – если треугольника не существует. кавычки выводить не нужно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
EinLegoMan
07.10.2020 23:30
Program Triangle;
var a,b,c:real;
begin
Read (a,b,c);
if (a+b>c)and(a+c>b)and(b+c>a)
then
  if (a=b)and(b=c)and(a=c)
  then write ('Triangle is scalene')
  else
    if (a=b)or(b=c)or(a=c)
    then write ('Triangle is isosceles')
    else write ('Triangle is equilateral')
else write('Triangle is invalid');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота