olegl123
23.04.2021 04:33

Дано целое трехзначное число x составьте программу вычисления суммы и произведения цифр трехзначного числа x значения x ввести с клавиатуры

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lolii0ikolik
07.10.2020 23:22
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=abs(ReadInteger).Tostring.Select(x->x.ToDigit);
writeln('сумма цифр: ',a.Sum);
write('произведение цифр: ',a.Aggregate(Real(1),(x,y)->x*y));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота