nataliinfp0co9o
08.10.2022 19:37

Составить программу на паскале. вася делает за а часов, в минут, с секунд. ему необходимо выполнить n . сколько времени он потратит?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
reginа111222333
21.08.2020 10:58
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('Сколько часов, минут и секунд надо на задачу?');
  var n:=ReadInteger('Сколько задач?');
  var t:=n*(c+60*b+3600*a);
  Write('Будет затрачено ',t div 3600,' час ');
  t:=t mod 3600;
  Write(t div 60,' мин ',t mod 60,' c')
end.

Пример
Сколько часов, минут и секунд надо на задачу? 1 13 42
Сколько задач? 6
Будет затрачено 7 час 22 мин 12 c
0,0(0 оценок)
Ответ:
bubliknazar2003
21.08.2020 10:58
Var a,b,c,n:integer;
begin
readln(a);
readln(b);
readln(c);
readln(n);
a:=a*3600;
b:=b*60;
c:=(c+a+b)*n;
a:=c div 3600;
b:=(c div 60)-(a*60);
c:=c-(b*60)-(a*3600);
writeln('Часы: ',a,' Минуты: ',b,' Секунды: ',c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота