Напишите программу, которая проверяет, можно ли получить из одного имени другое путем перестановки его букв. при этом регистром букв нужно пренебречь. stop pots yes abbc bac no написать на paskal
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018 // Внимание! Если программа не работает, обновите версию!
begin // вводим строку, перекодируем к нижнему регистру и делим на два слова var a:=ReadlnString.ToLower.ToWords; var (n1,n2):=(a[0].Length,a[1].Length); // длины слов if n1<>n2 then begin Writeln('No'); exit end; for var i:=1 to n1 do begin var p:=Pos(a[0][i],a[1]); if p=0 then begin Writeln('No'); exit end; Delete(a[1],p,1) end; Writeln('Yes') end.
Примеры stop pots Yes
aBbC bAc No
ПароВоз ЗовоПар Yes
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку