Составьте программу в паскале для поиска: a)суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
А) uses crt; const n=10; var a:array[1..n] of integer; i,sum:integer; begin for i:=1 to n do begin a[i]:=random(100)-50; write(a[i]:4); if a[i]>0 then sum:=sum+a[i]; end; writeln; writeln('Сумма положительных элементов = ',sum); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку