gilsveta4
13.03.2020 23:20

1. составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2. составить программу, которая вычисляет сколько лет можно выполнять план по отлову рыбы, если запасы рыбы составляют а тонн, ежегодный прирост рыбы 25%, ежегодный план отлова с тонн. pascalabc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sashatitsky
07.10.2020 21:52
1)
Program n1;
var sum,k,a: integer;
begin
sum:=0;
k:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
k:=k+1;
readln(a);
end;
write('сумма: ',sum,'; срзнач: ',sum/k);
end.
2)
Program n2;
var a,c,sum: real;
k: integer;
begin
k:=1;
readln(a,c);
sum:=a;
repeat
sum:=sum+a*0.25;
k:=k+1;
until sum>=c;
write(k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота