Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ruslan424
07.10.2020 21:35
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ReadArrInteger(ReadInteger()).Where(x->x mod 8=0);
write('кол-во чисел, делящихся на 8 без остатка: ',a.Count(),'; сумма: ',a.Sum());
end.
0,0(0 оценок)
Ответ:
ЯнаВасиленко
07.10.2020 21:35
Program qq;
var a, b, c, d, e:integer;
BEGIN
d:=0;
e:=0;
writeln('Введите количество чисел');
readln (a);
writeln ('Введите числа');
for b:=1 to a do
begin

readln (c);
if c mod 8 = 0 then
d:=d+c;
e:=e+1;
end;
Writeln ('Количество чисел кратных восьми - ', e, '; Их сумма - ', d);
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота