LeysAn11234
09.09.2020 10:23

На языке pascal напишите программу, которая будет подсчитывать количество двоек, четвёрок и пятёрок, полученных за контрольную работу по при условии если в классе 32 человека. исходные данные вводятся с клавиатуры с соблюдением правил дружественного интерфейса.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kira2347
21.08.2020 09:59
ответ в файле:
0,0(0 оценок)
Ответ:
SherlockloveMoriarty
21.08.2020 09:59
Var
  A, i, k2, k4, k5, c, d, N: integer;
Begin
  Write('Введите количество учеников в классе: ');ReadLn(N);
  if (N = 32) then
  Begin
    c := 1;
    d := 5;
    WriteLn('Введите оценки учеников:');
    k2 := 0;
    k4 := 0;
    k5 := 0;
    i := 1;
    While i <= N do
    Begin
      Write('Оценка ученика №',i,': ');ReadLn(A);
      if (c <= A)and(A <= d) then
      Begin
        Case A of
          2: k2 := k2+1;
          4: k4 := k4+1;
          5: k5 := k5+1;
        End;
        i := i+1;
      End
      else
        WriteLn('Неприемлимое значение! Допустимые значения: [',c,'..',d,']');
    End;
    WriteLn('Количество двоек: ',k2);
    WriteLn('Количество четвёрок: ',k4);
    WriteLn('Количество пятёрок: ',k5);
  End
  else
    WriteLn('В классе не 32 ученика');
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота