DimaMartolog
30.03.2022 14:09

Напишите программу которая для введённой пары положительных чисел, большее число делит на меньшее до того, пока оно не станет меньше единицы

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sahabg
10.08.2020 21:23
П0 <-> П1 - x<0 13 ИП0 П2 ИП1 П0 ИП2 П1
ИП0 1 - x<0 22 ИП0 ИП1 / П0 ИП0 С/П
0,0(0 оценок)
Ответ:
7446457567
10.08.2020 21:23
Var
  a,b,t:real;

begin
  Write('Введите через пробел два положительных числа: ');
  Read(a,b);
  if b>a then begin t:=a; a:=b; b:=t end;
  repeat
    a:=a/b
  until a<1;
  Writeln(a)
end.

Пример
Введите через пробел два положительных числа: 1.7 153.4
0.760915000615007
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота