vadim88768
16.07.2020 05:22

Сна паскаль!
составить программу для решения : дано натуральное число n. вычислить , определяемое как произведение честных чисел от 2 до n, если n честно, либо как произведение нечетных чисел от 1 до n, если n нечетно.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nataljalevchen
07.10.2020 20:02

program raf105;

var

 n,pro: integer;

begin

 write('n = ');

 readln(n);

 pro:= n;

 while n-2 > 0 do

 begin

   pro:= pro * (n-2);

   n:= n - 2;

 end;

 writeln('Вывод: ',pro);

end.

PascalABC
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота