идинахер89
18.02.2023 07:39

Добрые люди ! решить данную на паскале напишите программу, чтобы создавала палиндром любой строки. палиндром - исходная строка + обратное представление строки (на входе – abc; на выходе abccba)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pepsy94zm
07.10.2020 19:54
1. Современное решение

// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  s:=s+s.Inverse;
  s.Println
end.

Пример
abc
abccba

2. Так все еще учат в большинстве (но уже не во всех!) школ

program Palindrom;

var
  s:string;
  i,n:integer;

begin
  Readln(s);
  for i:=Length(s) downto 1 do s:=s+s[i];
  Writeln(s)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота