ddonor89
19.08.2020 22:21

Все свои напишите программу, которая определяет прямоугольный ли треугольник. на ввод программе длины сторон треугольника.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Аня276541
07.10.2020 19:34
Var
a, b, c: real;
begin
  Read(a, b, c);
  if (a * a = b*b + c*c) or (b*b = a*a + c*c) or (c*c = b*b + a*a) then
    Writeln('Треугольник прямоугольный!')
  else
    Writeln('Треугольник непрямоугольный!')
end.

Пример:

3 4 5
Треугольник прямоугольный!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота