euno
23.05.2021 22:20

15. составить программу для вычисления суммы 2+4+6+8+…

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ksussshhhaaa
26.08.2020 21:28
Ряд 2,4,6,8... является арифметической прогрессией с разностью d=2, и первым членом a1=2
формула суммы первых n членов:
S_n= \frac{2a_1+d*(n-1)}{2}*n
в данной задаче:
S_n= \frac{2*2+2(n-1)}{2} *n= \frac{2n+2}{2} *n=n(n+1)=n^2+n
поэтому при составлении программы можно обойтись без циклов
программа:
Program n1;
var n: integer;
begin
readln(n);
write(n*n+n);
end.
0,0(0 оценок)
Ответ:
Kmamsmajfkf
26.08.2020 21:28
Program Rick_and_Morty;
var a,c:integer;
Begin
a:=0;
writeln('введите количество чисел');
readln (c);
while c>0 do
begin
a:=a+(2*c);
c:=c-1;
end;
writeln('ответ: ',a);
writeln('конец');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота