Войти
Регистрация
Спроси ai-bota
danil820
11.03.2022 14:02
Написать программу на pascal вычислить сумму квадратов вводимых чисел. числа вводятся, пока не будет нажат ноль.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
ruslapanazavr
23.07.2020 17:42
Сформировать квадратную матрицу порядка n по заданного образцу ( задачи 76,77,80)...
1Айжан11
11.05.2020 08:51
1. Компьютерные Вирусы это. (ВИДЫ) 2.Что собой представляет монитор.Виды мониторов. 3. Что такое сервер....
smaliar2004
22.06.2020 01:31
8. Определи значение переменной с после выполнения фрагментаалгоритмаа:=100;b:=30;а:=a-b*3;Если a b то с:=a-b иначе с:=b-а;...
BlackL706
16.09.2022 05:18
Какой объем видеопамяти необходим для хранения изображения размером 640 на 480 точек а глубина равна 32...
Niki152
16.09.2022 05:18
Решите . 1. статья, набранная с компьютера, содержит 71 страницу. на каждой странице – 35 строк. в каждой строке – 50 символов. каков объем информации в статье в кб? 2....
555Sasha444
13.10.2022 16:56
Для чего используется предворительный...
546jbj
17.05.2020 09:41
Қоспалардың түрлері сипаттап жаз ...
ANADTYEE
09.06.2022 04:07
8 сынып БЖБ 2 тоқсанс инфарматика...
MrLegolas
05.05.2022 04:01
Что изображено на фотографии?...
Катерина26121
15.05.2020 20:38
Точка о-центр правильного треугольника авс,ом-перпендикуляр,проведённый к плоскости авс.ом=корень из 3,ав=3 корня из 3.найти угол наклона ма к плоскости треугольника авс....
Ответ:
Fsyh
07.10.2020 17:28
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToArray();
a.Transform(x->x*x);
write(a.Sum());
end.
0,0
(0 оценок)
Ответ:
тупой810
07.10.2020 17:28
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.
Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота