natsvin2017
13.05.2020 17:10

Напишите программу [на pascal], которая вычисляет минимальное из трёх введённых чисел. используйте функцию.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Katyakat20050904
16.08.2020 16:18
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

function Min3(a,b,c:real):=Min(a,Min(b,c));

begin
  var (x,y,z):=ReadReal3('Введите три числа:');
  Writeln('Минимальное: ',Min3(x,y,z))
end.

Пример
Введите три числа: 3.18 -2 5.7
Минимальное: -2
0,0(0 оценок)
Ответ:
Бантюсик
16.08.2020 16:18
function min(x,y:integer):integer;
begin
if x<y then min:=x else min:=y;
end;
var a,b,c:integer;
begin
readln(a,b,c);
writeln('min = ',min(min(a,b),c));
end.

Пример:
8 2 5
min = 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота