Banger123Mary123
23.12.2021 08:53

Написать программу для подсчёта количества вхождений подстроки в строку. (язык с++)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Danya1111111111135
07.10.2020 16:10
#include <iostream>
#include <string>
using namespace std;
int main()
{
    string str, substr;
    cout << "String = "; getline(cin, str);
    cout << "Substring = "; cin >> substr;
    int cnt = 0;
    for(int i = 0; i < str.length(); ++i)
        if(str[i] == substr[0])
            if(str.substr(i, substr.length()) == substr)
            {
                ++cnt;
                i += substr.length() - 1;
            }
    cout << cnt;
    return 0;
}

//
Пример:
String = test testHelloWorld testtest1243test
Substring = test
5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота