Войти
Регистрация
Спроси ai-bota
оу1щи
12.04.2023 13:31
Написать программу на языке с программа должна считывать последовательность 25 чисел из файла, заменить все элементы, которые меньше среднего арифметического этих элементов, на 0 и вывести новую последовательность в новый файл
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Wulfmax
06.01.2020 11:53
Ввести предложение, где между словами не менее одного пробела. вывести слова в столбец....
emoe0zosixnc
06.01.2020 11:53
Гражданин петров взял в долг у своего приятеля сидорова 9800р., выдав последнему вексель, по которому обязался выплатить 10000р. через 3 месяца. под какой долговой процент...
Ника5324
18.02.2021 03:23
Сколько цветов будет содержать палитра если на один пиксель отводится 4 бита памяти?...
elsoc
07.08.2022 18:13
Сколько битов памяти достаточно для кодирования одного пикселя 16-цветного изображения?...
denus16
07.08.2022 18:13
Сколько цветов будет содержать палитра,если на один пиксель отводится 4 бита памяти?...
Lulu84
07.04.2022 07:37
В таблицах бд можно осуществлять поиск данных(записей),удовлетворяющих определённым условиям,который называется .. в)фильтромс)полема)формойе)числом...
uraalekseev1234
21.04.2023 16:27
1. Выбери названия 3D - редакторов, из предложенных, запиши их: 1 вариант (мальчики): Paint, Wings3d, Gimp, SketchUp, Фотошоп.2 вариант (девочки): 3dsMax, TuxPaint,...
arladich
13.05.2023 02:30
Объект,предназначенный для поочередного ввода,просмотра и редактирования записей в бд в)формулад)полес)формаа)запись...
Gdbxfg
22.06.2022 07:41
Герои или название предметов которые имеют необычный рост?...
AlinaAlinochka2008
25.06.2020 13:47
Известно, что в ящике лежат 10 чёрных шаров, 5 белых, 4 жёлтых и 1 красный. какое количество информации несут сообщения о том, что из ящика случайным образом достали...
Ответ:
daniltarakano13
07.10.2020 15:51
#include <stdio.h>
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота