ilgam2000
30.11.2022 06:42

Написать программу на с++. написать подпрограмму, которая находит максимальную цифру заданного числа и выводит её на экран.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikitasemechka
07.10.2020 15:51
#include <iostream>
using namespace std; 

void mxd(int n) {
    int k,mx=0;
    do {
       k=n%10; n/=10;
       if (k>mx) mx=k;
    }
    while (n>0);   
    cout<<mx<<endl; 
}    

int main() {   
    int n;
    cout<<"number: ";  cin>>n;
    mxd(n);
    system("pause");
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота