ekaterina2206
19.02.2021 11:37

Нужна по программированию. нужна пятёрка и я получу за четверть пять, . напишите программу в паскале. имеется одна коробка со сторонами а б с(вводятся с клавиатуры), ещё есть 1 коробка со сторонами x z t(вводятся с клавиатуры). надо ответить влезит ли первая коробка во вторую если коробки можно вращать.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
микки37
07.10.2020 15:26
Var a,b,c,x,z,t,k: integer;
begin
  write('a b c через пробел:  ');  readln(a,b,c);
  write('x z t через пробел:  ');  readln(x,z,t);
  if a>b then swap(a,b);
  if b>c then swap(b,c);
  if b<a then swap(a,b);
  if x>z then swap(x,z);
  if z>t then swap(z,t);
  if z<x then swap(x,z);  
  k:=0;
  if a>=x then 
     if (b>=z) and (c>=t) then k:=1;
  if (a<=x) then
     if (b<=z) and (c<=t) then k:=1;
  if k=1 then writeln('да')
  else writeln('нет');
end.

a b c через пробел:  10 7 3
x z t через пробел:  3 5 9
да

a b c через пробел:  8 5 7
x z t через пробел:  9 7 4
нет
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота