follizy
29.11.2020 20:33

Составить программу, которая заполняет массив, сортирует по убыванию, находит максимум м выводит его до и после сортировки.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nosovadascha20
07.10.2020 15:14
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  a:=a.OrderByDescending(t->t).ToArray; a.Println;
  Writeln('Максимум: ',a.First);
end.

Пример
n= 15
22 26 18 -12 44 44 44 50 -30 11 6 8 -22 2 25
50 44 44 44 26 25 22 18 11 8 6 2 -12 -22 -30
Максимум: 50
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота