nikzyk
29.02.2020 10:51

Написать программу на языке pascal для решения следующей : дан массив 4x4 из целых чисел. вычислить в массиве количество элементов равных пяти, имеющих чётные индексы строки. ввод массива, вычисление количества оформить в виде подпрограмм.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Touka1337
07.10.2020 14:58
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

function MatRead:array[,] of integer;
begin
  Writeln('Вводите элементы через пробел построчно');
  Result:=ReadMatrInteger(4,4)
end;

function PartCount(a:array[,] of integer):=
    a.ElementsWithIndexes.Where(t->(t[0]=5) and t[1].IsOdd).Count;

begin
  var a:=MatRead;
  Writeln('*** Исходный массив ***');
  a.Println(6); Writeln(6*a.ColCount*'-');
  Writeln('Искомых элементов: ',PartCount(a))
end.

Пример
Вводите элементы через пробел построчно
34 12 21 5 0 3 12 5 -6 18 5 16 5 -15 16 7
*** Исходный массив ***
    34    12    21     5
     0     3    12     5
    -6    18     5    16
     5   -15    16     7

Искомых элементов: 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота