Войти
Регистрация
Спроси ai-bota
lambert1337
04.11.2022 12:46
Информатика , 9 класс. паскаль . решит. 2. в первый день ученик выучил 3 ̆ских слова, а в каждый следующий день – на 1 слово больше, чем в предыдущий. составить программу для вычисления количества слов, выученных учеником за неделю.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
MigelAlemanValdes
02.05.2023 23:13
Как записывается данный алгоритм на языке Паскаль зарание...
Shmanin32
22.10.2020 06:29
Составить программу которая вычисляет сумму вклада в банке через N, лет если первоначальный взнос - M рублей, а процентная ставка - 8,5% годовыхДолжно получиться как...
kadalsu4
16.08.2021 17:06
Составьте блок-схему к следующему заданию:...
ivan497
11.09.2022 03:24
Обработка массива с++. Напишите программу к заданию в VB C++ (Задание и блок-схема в приложении)....
салемы
05.05.2021 09:09
Рассчитайте и выведите на экран количество рабочих часов в месяце, если продолжительность рабочего дня равна 8 часам в день, а число рабочих дней в месяце запрашивается...
sukaheva
25.12.2022 07:14
Задание 1: Дано трёхзначное число, определить есть ли среди цифр данного числа 4. Задание 2: Дано трёхзначное число, определить, равны ли первая и последняя цифры в...
1amon1
25.12.2022 07:14
по информ! 4класс п.19 там во во можно ли управлять объектом о котором тебе известно только его имя?!...
KolbasaBatonSir
28.10.2020 14:38
Решить задачу на языке Паскаль: Задан двумерный целочисленный массив А из n строк и m столбцов (1 ≤ n, m ≤ 10). Составить программу, которая организует одномерный массив,...
agadoraaa
04.04.2021 19:46
Cоставьте блок-схему или алгоритм на школьном алгоритмическом языке вычисления идеального веса человека. Значение роста вводится с клавиатуры....
Некитсоловей
27.08.2022 14:22
Определите число, которое будет напечатано в результате выполнения программы. var n, s: integer; begin n := 10; s := 0; while s = 249 do begin s := s + 24; n := n +...
Ответ:
nastya23rwa
07.10.2020 14:44
Var k,s,i:integer;
begin
k:=3;
s:=3;
for i:=2 to 7 do
begin
k:=k+1;
s:=s+k;
end;
writeln('Количество выученных слов = ',s);
end.
Результат:
Количество выученных слов = 42
0,0
(0 оценок)
Ответ:
emilgaripov87
07.10.2020 14:44
Пусть в первый день ученик выучил k слов.
Тогда за n дней он выучит
Теперь можно написать программу. Известно, что k=3, n=7.
Ручной счет дает 3×7+6×7/2 = 21+21 = 42.
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (k,n):=(3,7);
Writeln(k*n+n*(n-1) div 2)
end.
Результат
42
Хорошая иллюстрация случая, когда для решения задачи компьютер не нужен. Так бывает, когда составители заданий думают тем, на чем сидят.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота