Yascher
22.06.2020 06:13

Написать программу на с программа, которая переводит заданое число из восьмиричной системы в пятиричную

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
алка689338
07.10.2020 12:57
Замечание: контроль правильности ввода не выполняется.
#include <stdio.h>

int main(void) {
  int a_8, a_10, a_5, b, c;
  printf("Введите число в восьмеричной системе счисления: ");
  scanf("%d",&a_8);
  b = a_8;
  a_10 = 0; c = 1;
  while (b>0) {
    a_10 += c*(b % 10);
    c *= 8;
    b /= 10;
  }
  b = a_10;
  a_5 = 0; c = 1;
  while (b>0) {
    a_5 += c*(b % 5);
    c *= 10;
    b /= 5;
  }
  printf("%d(8) = %d(10) = %d(5)",a_8,a_10,a_5);
  return 0;
}

Пример:
Введите число в восьмеричной системе счисления: 2014
2014(8) = 1036(10) = 13121(5)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота