Войти
Регистрация
Спроси ai-bota
л270103л
02.04.2020 16:35
Паскаль. с клавиатуры вводится натуральное число x. требуется получить число y, в котором записаны цифры числа x в обратном порядке. например, x=123 y=321. примечание. решите с рекурсивной процедуры. 50
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
adelinathebest
11.05.2023 05:03
Перевести число 432 в семиричную и девятичную системы счисления...
Mas4323
10.08.2020 18:13
Синформатикой. , с объяснениями...
58722001
28.03.2021 06:48
На 4 9. на стене наклее друг на друга в.. 4 -резанные из газеты слова «один», «два», «гри», «четы- ре», что выглядит как «чтдвадин». у укажите два слова, которые были...
platonnikitos
27.12.2020 11:29
Две истины + две истины= что получится? ! ...
ромамс
22.03.2023 15:01
Определите значение логического выражения: f=not (x or y) (при x=1,y=0) 1)f=0, 2)f=1, 3)f=2, 4)f=3 f=not(1 or 0)=not 1=0...
Alina104969
18.07.2020 03:52
Вкакой части окна нужно разместить указатель мыши чтобы поменять его размер...
znarineozszf8
26.12.2021 22:45
Написать программу на visual basic (vba). в программу вводят стороны прямоугольника а и в . программа выводит рисунок цветного закрашенного прямоугольника.можно написать...
nlapenko
28.08.2021 14:13
Завтра олимпиада.я прорешиваю сейчас года.access програма в которой надо это сделать. напишите ответ в подробностях как это сделать...
mynomynou
21.11.2022 09:42
Составление таблиц истинности...
arina121212
17.11.2020 17:53
нужно сделать все что на фоото.где непонятный знак,(это он & ).желательно расписать.это информатика,тема( логики)...
Ответ:
svetika0813
07.10.2020 11:50
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
procedure Rvr(var n,nr:BigInteger);
begin
if n<>0 then begin
nr:=nr*10+ n mod 10;
n:=n div 10;
Rvr(n,nr)
end
end;
begin
var nr:=BigInteger(0);
var n:=ReadlnString('Введите натуральное число:').ToBigInteger;
Rvr(n,nr);
Writeln(nr)
end.
Пример
Введите натуральное число: 234536406567867348292735385468776123478182736
637281874321677864583537292843768765604635432
0,0
(0 оценок)
Ответ:
mari523
07.10.2020 11:50
Var X, Y: longint;
procedure revX(X: longint; var Y: longint);
begin
if X <> 0 then
begin
Y := Y * 10 + (X mod 10);
revX(X div 10, Y);
end;
end;
begin
write('Введите X = ');
readln(X);
revX(X, Y);
writeln(Y);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота