kz2388
23.10.2020 10:30

Написать программу замещения первой половины строки второй а второй первой в с++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ксюшка3215
07.10.2020 11:19
#include <iostream>
#include <string>

using namespace std;

int main()
{
    string a;
    char temp;
    cin >> a;
    for (int i = 0; i < a.size() / 2; ++i) {
        temp = a[i];
        a[i] = a[a.size() / 2 + i];
        a[a.size() / 2 + i] = temp;
    }
    cout << a;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота