666777зпа
22.07.2022 08:02

Написать программу : дан двумерный массив а, состоящий из n элементов. найти минимальный из элементов этого массива с нечетными индексами и максимальный из элементов с четными индексами.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Сетора11
04.08.2020 06:58
Var
  a: array [1..100] of integer;

begin
  var N := ReadInteger;
  var mmax := Integer.MinValue;
  var mmin := integer.MaxValue;
  for var i := 1 to N do
  begin
    readln(a[i]);
    if (i mod 2 <> 0) and(a[i] < mmin) then mmin := a[i];
    if (i mod 2 = 0) and (a[i] > mmax) then mmax := a[i]
  end;
  writeln('Минимальный элемент массива с нечетным индексом: ', mmin);
  writeln('Максимальный элемент массива с четным индексом: ', mmax)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота