azalhanovahalid
13.04.2022 05:34

Составить программу в паскаль. дана последовательность из 10 чисел (2,3,-15,4.4,0,-3.2,3,25,-5,0). найти произведение положительных элементов и количество отрицательных элементов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kamillka005
07.10.2020 10:23
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=Arr(2.0,3.0,-15.0,4.4,0.0,-3.2,3.0,25.0,-5.0,0.0);
  a.Println;
  Writeln('Произведение положительных= ',
      a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y));
  Writeln('Количество отрицательных= ',a.Where(t->t<0).Count)
end.

Результат
2 3 -15 4.4 0 -3.2 3 25 -5 0
Произведение положительных= 1980
Количество отрицательных= 3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота