Tamalova5
05.11.2022 07:51

Вмассиве 8 элементов напишите программу которая находит сумму положительнух чмсел и кол во чисел =0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
jansayabektasova
07.10.2020 10:07
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(8,-9,9); a.Println;
  Writeln('Сумма положительных ',a.Where(t->t>0).Sum);
  Writeln('Количество нулей ',a.Where(t->t=0).Count)
end.

Пример
2 6 -6 7 0 2 3 6
Сумма положительных 26
Количество нулей 1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота