75 ! напишите программу, которая в списке из десяти случайных целочисленных элементов из диапазона от 0 до 100 находит максимальный чётный и минимальный нечётный элементы.
PascalABC.NET Версия 3.3. сборка 1583 (25.11.2017)
var a:array[1..10] of integer; begin var max:=2; var min:=101; for var i:=1 to 10 do begin a[i]:=random(0,100); write(a[i],' '); if (a[i] mod 2=0) and (a[i]>max) then max:=a[i]; if (a[i] mod 2=1) and (a[i]<min) then min:=a[i]; end; writeln; writeln('Минимальный нечетный елемент - ',min); writeln('Максимальный четный елемент - ',max); readln; end.
//Pascal var A: array [1..10] of byte; i, min, max: byte; begin randomize; min := 101; max := 0; for i := 1 to 10 do begin A[i] := random(101); if ((A[i] < min) and (A[i] mod 2 <> 0)) then min := A[i]; if ((A[i] > max) and (A[i] mod 2 = 0)) then max := A[i]; write(A[i], ' '); end; writeln; writeln('Максимальный четный = ', max); writeln('Минимальный нечетный = ', min); readln; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку