eynulla
04.09.2020 05:21

Составьте программу которая формирует массив из 16 случайных чисел от -20 до 20 и подсчитывает количество отрицацельных элементов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
popovaviktoriy3
07.10.2020 09:39
1)
const n=16; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(41)-20;
 write(a[i]:4);
 end;
writeln;
k:=0;
for i:=1 to n do
 if a[i]<0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
-14 -7 -20 -3 12 9 -5 -4 7 11 -14 7 6 13 10 12
k = 7

2)
begin
  var a:=ArrRandom(16,-20,20); a.Println;
  var k:=a.Where(x->(x<0)).Count;
  writeln('k = ',k);
end.

Пример:
7 9 -12 12 -7 -14 -16 15 18 -8 -5 -11 1 19 11 5
k = 7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота