Курьяма1
03.02.2021 21:58

Составить программу, определяющую длину самого короткого слова в предложении. если можно, то с объяснением. 25 .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sergo3g123g
26.08.2020 19:33
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadlnString.ToWords;
  var i:=a.Select(t->t.Length).ToArray.IndexMin;
  Writeln('Самое короткое слово "',a[i],'" длиной ',a[i].Length)
end.

Пример
Зеленые бесцветные идеи яростно спят
Самое короткое слово "идеи" длиной 4
0,0(0 оценок)
Ответ:
огпгпощо
26.08.2020 19:33
Var i1,i,k,sl,min:integer;
s:string;begin
min:=1000;
k:=0;
readln(s);
s:=s+' ';
for i:=1 to length(s) do 
if s[i]=' ' then k:=k+1;
for i:=1 to k do begin
i1:=1;
while s[i1] <> ' ' do
begin
sl:=sl+1;
i1:=i1*k+1;
if s[i1]=' ' then begin
if sl<min then min:=sl;
sl:=0;
end;
end;
end;
writeln('Длина наименьшего:',min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота