крмоири
15.01.2023 21:21

Составить программу для вычисления суммы факториалов всех четных чисел от m до n.(matlab)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
natalia22082000
07.10.2020 09:04
Var
 i,m,n,s:integer;

function fact(a:integer):integer;
var l:integer;
begin
 l:=1;
 for i:=2 to a do
 l:=l*i;
 fact:=l;
end;

begin
 read(m);
 readln(n);
 s:=0;
 for i:=m to n do
  if i mod 2=0
   then s:=fact(i)+s;
 writeln('Suma: ',s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота