Войти
Регистрация
Спроси ai-bota
slavinka17
24.06.2022 00:26
Напишите программу, которая вычисляет количество цифр числа. используйте функцию.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
агамтасия
07.12.2021 05:32
Рассчитать объем памяти необходимый для черно белого (палитра из 2 цветов) пятиминутного мультфильма на экране монитора с разрешением 800 на 600 пикселей, ответ переведите в байты...
lisafoxxxxxxxx
24.03.2022 16:47
Определите значение переменной S после выполнения фрагмента программы: Алгоритмический язык: S :=0 n :=6 для i от 2 до n шаг 1 нц S := S+2*i кц Печать S Варианты ответа 1.10 2.40...
79366
24.03.2022 16:47
Скиньте во с учебника информатики босова 6 класс стр 1271,2,3 заранее...
Grif69
16.11.2020 08:09
Является ли треугольник a b c равнобедренным? только не по правилу паскаля...
zeroone01
16.11.2020 08:09
Вставь пропущенные слова система команд исполнителя это всех команд которые исполнитель может выполнить - это подробный план последовательности действий, описывающий решения...
NastyaMishacheva
11.11.2022 00:23
:разработайте алгоритм, который получает на вход слово и число, а затем выводит это слово указанное число раз. [псевдокод]...
Деструктивный
15.11.2022 06:04
Нкпишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчиващихся на 3...
Fentis001
15.11.2022 06:04
Как запустить компиляцию программы? коротко...
PISOS228XYI
15.11.2022 06:04
Сколько байт килобайт занимает одна страница текста, если в одной строке помещается 40 символов, а на странице 40 строк? каков объем одной книги, состоящей из 130 подобных страниц...
ponk4ik228778
23.12.2021 22:22
5.1. Реализуем сценарий Узнаете Как разрабатывать и реализовывать сцена рии в игровой среде программирования. Как находить и исправлять ошибки в про грамме. Ключевое слово Среда...
Ответ:
ilyuza2004p06tr4
10.08.2020 18:28
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
function nDigits(n:int64):integer; // если число
begin
Result:=0;
if n<0 then n:=-n;
while n>0 do begin
Result+=1;
n:=n div 10
end
end;
function nDigits(s:string):=s.Length; // если строка
begin
Writeln(nDigits(1234567890123456)); // 16
Writeln(nDigits('123456789012345678901234567890')) // 30
end.
Результат
16
30
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота