xdxdxdxdxdxdx
05.04.2020 10:18

Составьте программу которая формирует массив из 13 случайных чисел, от 0 до 30, меняет местами 4-й и 9-й элементы и выводит значения элементов массива на экран до и после обмена. pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Deloroza
01.09.2020 11:40
Const n=13;
var a:array[1..n] of integer;
i,c:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
c:=a[4]; a[4]:=a[9]; a[9]:=c;
for i:=1 to n do write(a[i]:4);
writeln;
end.

Пример:
Массив A:
11 25 20 0 7 28 27 26 23 25 12 24 20
11 25 20 23 7 28 27 26 0 25 12 24 20
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота