Kanat2K4
31.03.2022 23:47

Нужно составить программу к решению : "дано число n. перевернуть число".

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
отличник722
07.10.2020 06:58
Var
  n, m: longint;
begin
  m:=0;
  readln(n);
  while n > 0 do 
  begin
    m := m*10 + n mod 10;
    n := n div 10;
  end;
  writeln(m);
end.

Пример:
13804
40831
0,0(0 оценок)
Ответ:
girldasha1
07.10.2020 06:58
Var
  n, res, m: longint;
  s: string;

begin
  readln(n);
  while n <> 0 do
  begin
    m := n mod 10;
    s := s + (m.ToString);
    n := n div 10;
  end;
  res := s.ToInteger;
  writeln(res);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота