jorik9
08.09.2022 21:36

Нужно написать программу, которая переводит число из 16-ой сс в 10-ю сс, на языке c.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Арусяк122
07.10.2020 06:39
#include <stdio.h>

int main(void) {
int n;
printf("Введите число в 16-ричной СС: ");
scanf("%x",&n);
printf("%x(16) = %d(10)",n,n);
return 0;
}

Пример:
Введите число в 16-ричной СС: a1f
a1f(16) = 2591(10)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота