lspkorvo
15.10.2022 20:41

Составить программу на языке c++! дано натуральное число n. выведите слово yes, если число n является точной степенью двойки, или слово no в противном случае. операцией возведения в степень пользоваться нельзя!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nastya0012005
07.10.2020 06:09
#include <bits/stdc++.h>
using namespace std;
int main(){

int n;
cin >> n;
if (n <= 0)
{
    cout << "NO";
    return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
    cout << "YES";
else
    cout << "NO";
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота