Tumkanator
12.06.2022 15:20

Написать программу на си. составить программу, определяющую, в каком из данных двух чисел больше цифр.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ksyushay02
07.10.2020 06:04
#include <stdio.h>

int main(void) {
 int a1,a2,b,k1=0,k2=0;
 printf("a1 = ");
 scanf("%d",&a1);
 printf("a2 = ");
 scanf("%d",&a2);
 if (a1>0) b=a1; else b=-a1;
 while (b>0) {
  k1++; b /= 10;
 }
 if (a2>0) b=a2; else b=-a2;
 while (b>0) {
  k2++; b /= 10;
 }
 if (k1>k2) printf("В числе %d больше цифр, чем в числе %d",a1,a2);
 else if (k2>k1) printf("В числе %d больше цифр, чем в числе %d",a2,a1);
  else printf("Количество цифр в числах одинаково");
 return 0;
}

Пример:
a1 = 153
a2 = -4680
В числе -4680 больше цифр, чем в числе 153
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота