manafin1
14.08.2021 20:41

Парни : d нужно написать программу на паскале что бы она вычисляла сумму значения элементов трехмерного массива тип longin, 2x2x2 (вроде бы,короче че то 2 на 2 : d)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
irina2000barano
07.10.2020 05:39
Если будет ошибка на строчке:
      write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
можешь просто убрать ее.
Она может не работать из за разных версий Pascal-я, т.к. не везде есть IntToStr.

--------------------------------------------------------------------

var
  A: array [1..2,1..2,1..2] of longint;
  i, j, k: byte;
  sum: longint;
begin
for i := 1 to 2 do
  for j := 1 to 2 do
    for k := 1 to 2 do
    begin
      write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
      ReadLn(A[i, j, k]);
    end;
sum := 0;

for i := 1 to 2 do
  for j := 1 to 2 do
    for k := 1 to 2 do
      sum := sum + A[i, j, k];

writeln('Сумма всех элементов трехмерного массива = ', sum);
readln;
end.

Парни : d нужно написать программу на паскале что бы она вычисляла сумму значения элементов трехмерн
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота