Войти
Регистрация
Спроси ai-bota
Skeletron129
08.02.2022 18:29
Запрограммируйте текстовый квест с использованием switch, case и т.д, должно быть 10 вопросов на тему персонажа дефстроук и в конце надо вывести результат - насколько хорошо ты его знаешь
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
kristina150017584969
01.10.2020 13:29
Какие языки в настоящее время являются самыми распространяемыми в мире?...
Nanko11
11.12.2020 13:10
Вычислить по информатике, 50 , , пример в файле ниже , сделать только номер 4...
Майя123
15.11.2020 03:21
Выберите не язык программирования а) fortan b)c# c) delphi d) dev e)java...
umkhaev013suleiman
14.07.2021 03:42
Определи расстояние на плоскости между двумя точками с заданными координатами M1(x1,y1)и M2(x2,y2). ответ введи целым числом. Если координаты точек: x1=5;y1=2x2=9;y2=10. ответ...
qRinaTeinaq
07.09.2022 06:37
в C# Сумма степеней Входные данныеВводится натуральное число N, которое не превосходит 30.Выходные данныеВычислите 1+2+2^2+2^3+…+2^N....
nika06102007
27.10.2021 08:57
Из предложенного списка переменных исключи 1 лишнюю. Варианты ответов: a, p, k, m....
t0l1k
15.03.2023 23:07
Смеси (traits, mixins) как промежуточное звено между интерфейсами и наследованием....
jeni1955ma
08.09.2022 15:40
Выполни действие и запиши верный ответ.28 mod5=...
Олeксандра
29.01.2021 00:55
Объясните выражение: «когда умирает один человек, умирает целый мир»? ?...
natalinatali2003
27.02.2022 05:57
Has got илиhave got 1 today 2 at school 3 he at school 4 every day 5. the every day. 6. 7. my toy duck. 8. nice duck 9. jane and nice garden 10. larisa and today...
Ответ:
diana2010123456
07.10.2020 05:02
#include <iostream>
using namespace std;
int main() {
int a;
int b;
cout << "Привет, сегодня ты пройдешь тест по персонажу 'Дефстроук'" << endl;
cout << "Начнем!" << endl;
cout << "1.Какое настоящее имя персонажа?" << endl;
cout << "1-Стивен роджерс" << endl;
cout << "2-Брюс Вейн" << endl;
cout << "3-Джозеф Уилсон" << endl;
cout << "4-Питер Паркер" << endl;
cin >> a;
switch (a) {
case 3:
b += 1;
break;
}
cout << "2.Какой цвет глаз у персонажа?" << endl;
cout << "1-Зеленый" << endl;
cout << "2-голубой" << endl;
cout << "3-Коричневый" << endl;
cout << "4-Серые" << endl;
cin >> a;
switch (a) {
case 2:
b += 1;
break;
}
cout << "3.Когда появился этот персонаж?" << endl;
cout << "1-1970" << endl;
cout << "2-1985" << endl;
cout << "3-1990" << endl;
cout << "4-1980" << endl;
cin >> a;
switch (a) {
case 4:
b += 1;
break;
}
cout << "4.Какой цвет волос у персонажа?" << endl;
cout << "1-голубой" << endl;
cout << "2-зеленый" << endl;
cout << "3-белый" << endl;
cout << "4-чёрный" << endl;
cin >> a;
switch (a) {
case 3:
b += 1;
break;
}
cout << "5.Какой род занятий у персонажа?" << endl;
cout << "1-Наемник" << endl;
cout << "2-Бухгалтер" << endl;
cout << "3-Продавец" << endl;
cout << "4-Повар" << endl;
cin >> a;
switch (a) {
case 1:
b += 1;
break;
}
cout << "6.Какие враги у персонажа?" << endl;
cout << "1-капитан америка, супер мен" << endl;
cout << "2-Человек паук, железный человек" << endl;
cout << "3-Бэтмен, зелёная стрела" << endl;
cout << "4-Халк, капитан очевидность" << endl;
cin >> a;
switch (a) {
case 3:
b += 1;
break;
}
cout << "7.Персонаж:?" << endl;
cout << "1-Супергерой" << endl;
cout << "2-Суперзлодей" << endl;
cout << "3-Нейтрал" << endl
cin >> a;
switch (a) {
case 2:
b += 1;
break;
}
cout << "8.Имя персонажа на англ.?" << endl;
cout << "1-Deathstrike" << endl;
cout << "2-killstroke" << endl;
cout << "3-killer" << endl;
cout << "4-DeathSroke" << endl;
cin >> a;
switch (a) {
case 4:
b += 1;
break;
}
switch (b) {
case 1:
cout << "Вы ужасно знаете персонажа" << endl;
break;
case 2:
cout << "Вы ужасно знаете персонажа" << endl;
break;
case 3:
cout << "Вы плохо знаете персонажа" << endl;
break;
case 4:
cout << "Вы плохо знаете персонажа" << endl;
break;
case 5:
cout << "Вы неплохо знаете персонажа" << endl;
break;
case 6:
cout << "Вы неплохо знаете персонажа" << endl;
break;
case 7:
cout << "Вы отлично знаете персонажа" << endl;
break;
case 8:
cout << "Вы полностью знаете персонажа" << endl;
break;
}
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота