Войти
Регистрация
Спроси ai-bota
Eldar1001
15.01.2023 18:11
25 ! дан массив из 20 вещественных чисел. найти среднее арифметическое чисел элементов массива и заменить на него максимум и минимум элементов массива стоящие на местах кратных 5
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
DashSHAD0W
20.08.2022 01:10
Составить схему нахождения площади треугольника если извесно все его три стороны...
Софийка646436
20.08.2022 01:10
Turbo pascal ввести два числа. если сумма этих чисел четная, найти произведение, в противном случае, найдите частное этих чисел? . за ранее...
geamget
20.08.2022 01:10
Как изменится информационный объем страницы текста (текст не содержит символов форматирования), при преобразовании из кодировки koi - 8 в кодировку unicode....
lenochkasadyho
05.06.2020 06:55
Определите значение переменной «a» после выполнения программы....
kisakz12
30.04.2023 13:31
9класс жардамдашып койгулачы....
Liz1ka
20.01.2020 09:31
Почему выдает ошибку(python) File C:\piton\26.py , line 4, in for i in (n): TypeError: int object is not iterable...
zhenyaminaev2
02.02.2023 18:30
Информационный объем одного сообщения составляет 150 байт, а другого – 800 бит. На сколько байтов информационный объем первого сообщения больше объема второго сообщения надо...
cystan98
02.02.2023 18:30
Определите минимальное основание системы счисления, в которой могут быть представлены все следующие числа: 356, 776, 455....
TTpopoK
15.02.2022 10:38
Какой главный недостаток финийского письма...
Wolffy
15.02.2022 10:38
Автоматическое устроиство осуществило перекодировку информационного сообщения на языке ,первоначально записанного в 16-битном коде unicode,в 8-битную кодировку кои-8.насколько...
Ответ:
13alla68
07.10.2020 04:13
C++14
#include <iostream>
#define K 20
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
float arr[K], mid = 0;
cout << "Исходный массив: ";
for(size_t i = 0; i < K; ++i){
arr[i] = (rand() % 50000 - 25000)/17.0; // Заполняем случайными числами
mid += arr[i];
cout << arr[i] << " ";
}
mid /= K;
cout << endl << "Среднее арифм.: " << mid << endl;
int minI, maxI;
minI = maxI = 5*1;
cout << "Результирующий массив: ";
for(size_t i = 2; i < K/5; ++i){
if(arr[minI] > arr[5*i])
minI = 5*i;
if(arr[maxI] < arr[5*i])
maxI = 5*i;
}
arr[maxI] = arr[minI] = mid;
for(size_t i = 0; i < K; ++i)
cout << arr[i] << " ";
cout << endl;
system("pause");
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота