Войти
Регистрация
Спроси ai-bota
Анндрейй
22.07.2022 07:40
Решить по pascal. дано числа a1, a9; b1, b11. максимальный элемент первой последовательности заменить на максимальный элемент второй последовательности и наоборот. программу оформить в виде "процедуры"
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
меркульева
14.11.2021 17:22
Маша решила купить ткань для пошива штор, при чем шторы должны быть длинной Х метров. Ткань для штор стоит R руб. за квадратный метр. Сколько будет стоить ткань для штор, если ткань...
mashakostyuk8
19.07.2021 19:34
Почему в Excel значение функции синуса 180 и 360 градусов неправильно высчитывается, а со значением синуса 90 и 270 градусов все в порядке?...
rufdiana
24.05.2020 22:13
Приведи по 4 примера к Логическому умножению, логическому сложению, логическому отрицанию Информатика...
ащя
01.10.2022 05:06
Скласти програму, яка передбачала б введення послідовності символів та : Визначте, 10 найчастіше зустрічаємих послідовностей з N слів у тексті. N вказується користувачем....
Cobra237
18.12.2022 12:54
Ребт с этим. вроде не так сложно ))) 35 даю ...
Александа7
20.08.2022 12:00
Валя шифрует русские слова, записывая вместо каждой буквы её код...
ellia2
15.07.2021 10:29
Паскаль,задачки Задача 1. Максимальные непрерывные работы за компьютером детей ориентировочно такие: 6-8 лет - 15 минут, 9-11 лет - 30 минут, 12-15 лет - 45 минут, 16-17 лет - 60...
moto5
31.07.2022 00:48
7. Сколько существует различных последовательностей из сим волов «плюс» и «минус» длиной ровно пять символов?...
AsdZaKAsd
08.08.2020 01:36
Нужно написать программу на паскаль по массивам, чтобы из чисел от 2 до 10 выводились случайные числа, а после из них уже четные....
nikafolz
25.12.2021 07:23
без обмана, фото задачи ниже: А еще найдите ошибки...
Ответ:
даша3549
09.09.2020 23:14
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!
procedure AB(a,b:array of integer);
begin
var (iaMax,ibMax):=(a.IndexMax,b.IndexMax);
var t:=a[iaMax]; a[iaMax]:=b[ibMax]; b[ibMax]:=t
end;
begin
var a:=ArrRandom(9,-99,99);
Write('A: '); a.Println;
var b:=ArrRandom(11,-99,99);
Write('B: '); b.Println;
AB(a,b);
Write('A: '); a.Println;
Write('B: '); b.Println;
end.
Пример
A: -46 -76 98 -83 84 8 -14 46 8
B: 29 -36 37 78 -20 35 -77 -23 80 -50 -55
A: -46 -76 80 -83 84 8 -14 46 8
B: 29 -36 37 78 -20 35 -77 -23 98 -50 -55
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота