Войти
Регистрация
Спроси ai-bota
JadenGirl
03.05.2022 23:16
Написать программу в с++ проверить входит ли в заданную последовательность символов каждая из букв слова key
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Urinasonya
05.06.2023 21:17
Вставить слова)) а). кнопка backspace программы калькулятор предназначен для б). кнопка ce программы калькулятор предназначен в). кнопка с программы калькулятор предназначен зарание...
nikadidok
05.06.2023 21:17
Заполнить массив случайными числами в интервале [2; -2] и подсчитать количество положительных элементов...
MrLeysanHD
02.11.2022 18:48
Определи какой графики относятся данные программы векторной или Ростовой...
Enotlk1337
16.05.2022 10:06
Как составить программу вычисления y=(cosx2+sin2x)*2|x|/log2(x+1)2...
rivvas
16.05.2022 10:06
Дано трехзначное целое число. найти произведение этого числа на разность максимального и минимального чисел, составленных их цифр исходного числа. например для заданного числа...
Милка1111111111117
13.02.2020 06:35
Вчем преимущества хранения компьютерных тестов?...
Няшня
02.11.2021 09:39
Сосьавить программу назождения среднего арефметического двух чисел...
Катяhfhfyvdhvxd
03.01.2021 00:25
Замените все элементы массива ,стоящие на позиции кратной 3, на 0...
wwwem8
12.08.2021 09:47
Придумать и описать структуру таблицы базы данных, которая содержит четыре поля различных типов: символьного, числового (целого или вещественного), дата, логического. таблица...
sarinasergeeva
28.10.2021 17:01
Ккаким последствиям может заряжение компьютера компьютерными вирусами...
Ответ:
TINAdTINA
07.10.2020 03:55
Кодяра ниже
#include <iostream>#include <string>using namespace std;int main() { setlocale(LC_ALL, "Russian"); string key = "key", buffer; cout << "Введите последовательность: "; cin >> buffer; bool *bitmap = new bool[key.length()]; for (int j = 0; j < key.length(); ++j) bitmap[j] = false; for(int i = 0; i < buffer.length(); ++i) for(int j = 0; j < key.length(); ++j) if (buffer[i] == key[j]) bitmap[j] = true; for (int j = 0; j < key.length(); ++j){ cout << "\"" << key[j] << "\""; if (bitmap[j]) cout << " есть!" << endl; else cout << " нет!" << endl; } system("pause"); return 0;}
Кодяра выше
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота